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Issue


We see messages coming from Crossware and then sit in a “deferred” state and pending delivery

Is a way to prevent it on these distribution groups, to allow mail to work correctly?

In the screen capture below details of a message trace:


 

Cause


Exchange Online mail servers do not accept email messages that do not specify a return path.
 

Resolution

 
1. Open Windows PowerShell


2. Run the following PowerShell command:

$LiveCred = Get-Credential


 
PLEASE NOTE: If you have Multi factor Authentication Enabled you will need to set up PowerShell using this Article: https://technet.microsoft.com/library/mt775114(v=exchg.160).aspx

3. Run the following PowerShell command:
 
$Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://ps.outlook.com/powershell/ -Credential $LiveCred -Authentication Basic -AllowRedirection
Import-PSSession $Session


4. The following PowerShell commands returns all the Distribution Groups where ReportToOriginatorEnabled is set to false
 
Get-DistributionGroup |Where-Object{($_.ReportToManagerEnabled -eq $FALSE) -AND ($_.ReportToOriginatorEnabled -eq $FALSE)}


5. For the Distribution Groups returned in the above list, which are used in Crossware Mail Signature.

Set the ReportToOriginatorEnabled to True. Below is the Powershell:
 
Set-DistributionGroup 'Name Of Distribution Group' -ReportToOriginatorEnabled $true

Example: Set-DistributionGroup ManagersManagers@crossware.onmicrosoft.com -ReportToOriginatorEnabled $true


6. Verify the Change, by running the Powershell Command
 
Get-DistributionGroup 'Name Of DL' | fl ReportToOriginatorEnabled

Example: Get-DistributionGroup ManagersManagers@crossware.onmicrosoft.com | fl ReportToOriginatorEnabled


 

Further Information

 
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